Affected systems have been rebooted, and we are seeing alarms clear.
Posted Jun 26, 2025 - 22:11 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 26, 2025 - 21:00 CDT
Scheduled
Some 3CX's in the PIT DC will be rebooted after normal operating hours to ensure future stability. For more details on whether this impacts you, please contact support.