Some eFax's failing to deliver
Incident Report for Voxtelesys
Resolved
The incident has been resolved, and successful eFax delivery rates returned to normal. Thank you for your patience as we worked to address the issue.
Posted Oct 08, 2024 - 17:17 CDT
Monitoring
We've identified an issue that may have impacted faxes sent through our eFax service between at 9:38 AM to 12:44 PM CST today. Some faxes may have been returned with the reason “Failed to Deliver - Error: Internal Failure”. A fix has been successfully implemented. If your faxes were impacted, please resend them at your convenience.

We will continue to monitor. Thank you for your patience and understanding.
Posted Oct 08, 2024 - 13:17 CDT
This incident affected: eFax (Inbound eFax, Outbound eFax).